Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EasyOS 2.4 released - NOT
#1
The blog post says it all:

https://bkhome.org/news/202008/easyos-ve...eased.html

Version 2.4 withdrawn, a couple of show-stopper bugs.

These got introduced in the last few hours before building 2.4. I probably shouldn't have kept working until 4.30 am to get it out!

I have discovered  the causes of both of them, stupid mistakes. I will probably release 2.4.1 in a couple of days, will take it a bit slower this time.

The two bugs are:

1: Gparted requires the DEB package 'libgtkmm-3.0-1v5'
2. A change that I introduced into /etc/rc.d/rc.sysinit has stuffed up the JWM menu and ROX mime handling. The code at "#200827" is wrong, it deletes most of the files in /usr/share/applications. A quick look at it, looks like line 318 should have "^Exec=" instead of "^Icon=".

Regarding number 2, if you are running 2.4 now, just delete those lines, from 309 to 332, then rebuild the jwm menu:

# fixmenus
# jwm -reload

Hmmm, but ROX mime handling is still broken, off the top of my head, can't think how to fix that.

If you are running 2.4 and discover anything else, let me know.

Reply
#2
# /usr/local/easy_version/easy-update  | tee  /home/easyupdate.log

**fix this code does now produce the require log file**

try this code instead of clicking update on the desktop.
it will hopefully l give you the output in that log file.
i have now tried it. 
(before fixing the code and not using the code:  my update seems to have hung with a number of errors going through

got to here " as attached" and its not going any further

drive i am installing to has 36G of free space and the partition hasn't recently been messed with, but my random vpn updater/changer has kicked in a couple of times already. this may have causes issue ..)


Attached Files Thumbnail(s)
   
Reply
#3
"ROX mime handling"
i have been copying the folders from past easyos even before 2.4 release
/root/.config/rox.sourceforge.net
and other stuff that it says is missing

attached is from 238 or earlier. cant remember. had thought it was caused by my mucking because no one else reported it. perhaps by my right-click pet installs/uninstalls.


Attached Files
.png   capture6333.png (Size: 11.85 KB / Downloads: 73)
.png   capture6938.png (Size: 10.75 KB / Downloads: 73)
Reply
#4
That JWM menu stuff-up caused lots of *.desktop files in /usr/share/applications to get deleted. if you comment-out that section of rc.sysinit, also go to /mnt/wkg/.session/usr/share/applications, and delete all the .wh.*desktop files, then immediately reboot.

You are not really supposed to edit the .session folder directly, as it is a layer in the aufs layered filesystem, but if you do it then reboot, all will be well, and you will have your .desktop files back.

Then, as I posted above, rebuild the jwm menu.

I have remembered how to fix the rox right-click mime handling, after the reboot, run this:

# build-rox-sendto
Reply
#5
A PET package is mime type application/pet, and ROX-Filer has a handler for it at /etc/xdg/rox.sourceforge.net/OpenWith/.application_pet

Note that /root/.config/rox.sourceforg.net/OpenWith is empty.

If you right-click on a PET package and select "Properties..." it will tell you the mime-type assigned to PET packages. if it isn't application/pet, then you have done something to change the mime types.

the mime type for PET packages is defined in /usr/share/mime/packages/puppy.xml

I think, from memory, the command to update the mime database from those .xml files, is "update-mime-database", then ROX should be getting the correct mime-type for PET packages. I think, from memory again, that command will re-create some files such as /usr/share/mime/magic and mime.cache
Reply
#6
thanks for the reply BK. sorry to trouble you. it seems my perception of whats in a basic setup is awry. after using right click pet forever i had assumed that basic stuff like Run in a terminal were in a standard easyos when in fact they aren't. can't use right click pet now because it causes other problem. populating all the other stuff is a bit of a nuisance.
Reply
#7
/usr/sbin/build-rox-sendto

https://bkhome.org/news/201805/rox-filer...-menu.html

this one seems to work others supplied didnt

edit still hasnt got everything needed but its a start . deletes what you got already eg run in terminal and defaultbrowser

i have
/usr/local/bin/

and
/usr/local/apps/

linked to the desktop so when i want to alter the right-click menu i just open those and drag something into the customize menu or "Open with" section

so this is solved for me can move on..
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)